3

In the below image example, the person has a taxonomy legend (lower right hand corner):

enter image description here

How did this person get the legend? From his blog:

After [adding taxonomy term fields] let's hop back to our Views settings for the calendar view. Go to "Format" and Calendar Items Settings. Here we have an awesome legend feature built right in.

Um, no we don't. So how come he has a taxonomy legend feature (i.e. vocabulary legend types) in his Views and I don't? See below from his blog:

enter image description here

All I see in mine is the below:

enter image description here

Notice that my term field pull-down is mysteriously blank. Something whacky is going on!

1
  • I'm guessing the list comes up when you choose a term field. But since your term field dropdown is empty, I'm assuming your entity/node type that you filtered with in your Views doesn't have a taxonomy reference field attached to it. – Beebee Nov 5 '12 at 14:09
1

To see an option in the term field as above (e.g. field_event_type) make sure you add the Taxonomy field to your view and select Create a label in the Configure Field options. The label you create will then appear in the term field. If you do this with multiple term fields that are added to the view you can use the drop down to select.

Not sure at this stage regarding the Legend option however.

0

Include the Vocabulary as a views field. The field wont't show in most calendar views anyways, but you can hide it from display.

0

This puzzled me for a few days .. indeed, you need to add the field from the ContentType; the field where you select the term.

0

I know that it's been a while, but it is still a valid question. I solved this very issue as follows:

  1. I installed Views Field View
  2. I created a view for the taxonomy terms that I am interested in
  3. I selected the title and Taxonomy term: term ID as fields to show. Only that the latter is excluded from presentation, and output rewritten as [tid]

in the (fullcalendar) target view, I added a footer: global: views field view and chose the view created in the first place.

And voilà, that did the trick for me.

HIH

0

You have to set the label first of the term field.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.