A content type have image field. When uploading image as admin, everything works fine. But If i logged in as a normal user, and click on upload , it gives error ahah http error alert!

Also found add another button also giving same error.

What could be the issue?

  • what error comes? – monymirza Nov 15 '12 at 7:36

What Drupal version do you use? May I have list of modules you have? What messages do you have in watchdog?

First think I have is drupal permission problem.

  • i think its D6. – monymirza Nov 15 '12 at 7:36

Go to the following URL and check if you have given required permissions to the image field.


If you want the normal user to access the image field, then you have to give required permissions to anonymous user.

  • "Also found add another button also giving same error." . So i dont think its permission problem, i have crosschecked permissions. Its something related to ahah! – Serjas Nov 17 '12 at 4:37

I solved creating a new equal content type. Lucky me it wasn't too late. The problem was because something in a migration

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.