0

I installed Pressflow on my Drupal 6 website by replacing core files. I only kept .htaccess, robots.txt and sites folder.

After that I got a lot of PHP errors, even after I change php.ini's error reporting.

So I checked Apache logs.

I had APC running on my site already and I noticed the following error happening frequently:

[apc-warning] Unable to allocate memory for pool.

It disappeared after I change APC memory to 16MB (it was 30MB) and restart Apache.

Although I can now load a few pages, I'm getting a white screen when trying to load home page and some other pages. Also, some regions of the page aren't showing up properly.

I tried clearing cache too.

Is there anything I'm missing?

  • 3
    Disable APC (apc.enabled=0) and see if it still happens. I seriously doubt that 16M is enough, especially when you are loading a page from a cold cache. – mpdonadio Nov 9 '12 at 20:17
0

My first step here would be try again. If you still get issues and there is nothing in the logs try increasing the memory limit.

Also there are some pressflow changes in htaccess, replace that roo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.