0

I am displaying a content type through a view, using a contextual filter to limit results to one per page (nid). I believe this is a simple/standard way of displaying content, but being new to drupal I could be wrong.

My problem is that the content is duplicated. First within an 'article' tag, and then where I'd expect it to show up (inside the view tags). I find it completely baffling because I don't even use the article content type. It's a problem I've had from the start, but I took the easy way out and simply hid the article content with display:none. But now, for some equally baffling reason, drupal has placed a new view I created inside the article tags - which of course means it doesn't show either. :-(

Why would drupal decide to send along my content inside the article tags?

I'm not sure if this is enough to go on, but I would be more than happy to provide more information.

Thanks for your time, Tobias

3
  • Unfortunately I don't understand at all what you are doing. I believe it's terminology problems, mainly because your use of the work "Tag" doesn't make sense to me at all. Duplicate results in Views is a common symptom of (mis)-using references between entities without understanding how they affect content lists. – Letharion Nov 23 '12 at 9:41
  • I was talking about HTML tags. Sorry for not being precise there. I found my error though, which was incredibly stupid. I had given the content an url alias so as to function as a page, which would of course send along the content. I had then added a view as described above, adding the content once again. Silly me. Sorry for the inconvenience. – Tobias Nov 25 '12 at 10:12
  • Glad you worked it out. Please post your solution as an answer and accept it, otherwise this question will remain in the un-answered queue. :) – Letharion Nov 25 '12 at 15:51
0

As per comments, I found my error:
I was talking about HTML tags. Sorry for not being precise there. I found my error though, which was incredibly stupid.
I had given the content an url alias so as to function as a page, which would of course send along the content. I had then added a view as described above, adding the content once again.
Silly me. Sorry for the inconvenience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.