2

I just created a content type with a field:images. Then I added some content and I create a View to show these content. Then the view shows the images (from the images field) Everything works fine but when I logout the anonymous user can not see the images.

As you can see in this picture I have "checked" Access content for anonymous user. But it doesn't work...

view picture.

What I need to do to make the images visible for anonymous users is to have 'checked' View field_images. You can see the picture.

view picture

my question: do I need to checked on every field I create to make them visible to anonymous users? Is there any way to set that any new create field should be visible to anonymous users.

Thanks

4

If there is no field permission module installed, all fields are always visible. So if you don't want to restrict any fields, then disable the content permissions module.

Once such a module is installed, it works as implemented by that module. And there is no way for such a module to guess the permissions you want (should it be visible to auth users only, or anon users too.. maybe only a specific role?), so it can only chose the safe way and does not grant anything automatically.

That is consistent with all other permissions, when you install a new module.

  • Thanks berdir. I had Content Access module enabled, as you said I disabled but now the images are not visible, maybe I need to delete and re-create the nodes again to rewrite their permissions? I tried flushing all caches but nope... – chefnelone Jun 14 '11 at 11:20
  • solved! when creating new content all fields are visible. – chefnelone Jun 15 '11 at 6:26
  • Strange, I don't know why this would happen. – Berdir Jun 15 '11 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.