0

I'm trying to do something which seems so simple, but is causing a huge headache. Simply put, I'm trying to get my blog onto google's feedburner. I've read all about this, but there doesn't seem to be a clear answer. I just get a cyriptic error from google feedburner that reads:

Received HTTP error code 400 while fetching source feed.

I then validate my blog feed through feedvalidator.org. Says it's validated But... gives the following message.

This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
line 38, column 0: Missing atom:link with rel="self" [help]

The help link seems useless, and I don't think this "recommendation" from feedvalidator is my issue (please correct me if I'm wrong). Nonetheless, I've installed http://drupal.org/project/views_rss as well as http://drupal.org/project/feedburner I've tried burning my feed through the feedburner module. But nothing seems to be validated right or wrong... Very confused and frustrated. It looks like there's a lot of Drupal folks having similar problems without a clear answer/tutorial.

Here's what I have:

  1. Drupal6 site. A blog page with numerous blog posts, each with a teaser. URL example.com/blog
  2. What appears like a valid RSS feed when I type in example.com/blog/feed This spits out some text which looks something like...

    ?xml version="1.0" encoding="utf-8"?> rss version="2.0" xml:base="https://example.com"
    xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:media="http://search.yahoo.com/mrss/"> channel> title>Example blogs link>https://example.com/blog description> language>en item>

  3. I've set up a google feedburner account.

  4. Installed RSS views and feedburner modules

I don't know what else to do. I keep getting that awful error through google feedburner...Received HTTP error code 400 while fetching source feed.

Hopefully someone out there can help. I'm sure others would appreciate some fix guidance on this issue as well.

Thanks!

0

This one is ugly on google's part. My site is https, and feedburner doesn't support SSL... I figured that out the hard way. I didn't want to muck around with my SSL settings given that it's a wildcard cert, so I figured out a painless workaround. 1. Subscribe to your blog feed through Google reader. 2. Create a bundle folder with your blog feed. 3. Grab the bundle URL (not https, which is the workaround) 4. Paste it into feedburner.

Done, google accepts that, and gives you a branded feedburner url.

I'm sure there's a better approach, but this was an easy workaround for those with https sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.