2

I use Wysiwyg module with CKeditor since months and all worked well. Wysiwyg module is linekd only wit my input-format "Full html" and this is granted to use to my role "Editor". it worked very good.

Unfortunately, since the last Drupal core update i have a big problem:

it seems that only Administrator users can use the FULL HTML text format, my other roles don't see that format and so also the Wysiwyg module doesn't appear.

I've done many checks and tests (permissions, cache etc) but the only thing i discovered is that is a problem of permission on the TEXT FORMAT and not on the wysiwyg module... The proof is that if i apply wysiwyg to the "Plain text" format, also the EDITOR role see the wysiwig editor.

how can i fix this problem? i also tried to remove and re-set the permissions for the role to use the "Full HTML" format

2

I've got the same issue because of js error 'once is not defined'. To fix an error I've added to my html.tpl.php:

<?php print $scripts; ?>
<script src="/misc/jquery.once.js"></script>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.