0

Webform in block is allowing to click on send button and redirecting to page view, without validation the fields even when they are empty.

so if I come to the website and click on submit (on my form in block) instead of validationd and showing the little popup it redirects me to the form page view url.

But when I start typing something in my email fieled, then after clicking on submit I get a popup that email is in wrong format etc.

How to correct the behavior so that the popup shows the message like "the field is empty" etc.

Is it a bug of webform or am I missing something?

0

This is because you somehow missed making the E-mail field mandatory.
You can do so by following the steps given below:

  1. Edit the existing webform content at : yourhost.com/admin/content and selecting edit for your webform.
  2. Click the "Webform" tab, and check the "MANDATORY" option for the required field.enter image description here
  3. Click "Save". Thats it!
| improve this answer | |
  • I have mandatory checked already. That is not a problem. It redirects me to the page with the form from the block which is worng. It should stay on the page where the block is located and show the error message to the user there underneath the field with no value entered. – Derfder Dec 7 '12 at 8:48
  • That's strange! I've never came across with such situation. Maybe some other module is changing the behavior of webform. Are you using custom module to implement form validation hooks? – AjitS Dec 7 '12 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.