0

I've made a view that contains a filter that the visitor can change. The problem is that it give the possibilities to filter trough a combobox:

  • Is equal to
  • Is not equal to
  • Contains
  • Contains any word
  • Contains all words
  • Starts with
  • Does not start with
  • Ends with
  • Does not end with
  • Does not contain
  • Length is shorter than
  • Length is longer than
  • Regular expression

I don't want them! I just want the user to see an input field and click "ok" (something like that). And the search would be "Contains all words".

How to do this?

2 Answers 2

2

in your exposed filter, is the "expose operator" option checked ?

This might be the obvious answer.

enter image description here

3
  • I still want the user to be able to fill in the field, but I just dont want him to be able to choose how the filter is applied. Commented Dec 7, 2012 at 12:08
  • 1
    That's the exacte purpose of this option :) Commented Dec 7, 2012 at 12:10
  • I couldn't see your picture because of the firewall in my enterprise. You were right, thank you! Commented Dec 7, 2012 at 12:45
1

Just uncheck the "Expose operator" option in the filter settings page, then the user will be forced to use the specific operator that you select.

enter image description here

4
  • I still want the user to be able to fill in the field, but I just dont want him to be able to choose how the filter is applied. Commented Dec 7, 2012 at 12:08
  • Yep, that's what turning that option off will do. The operator isn't the filter, it's how the filter is operated upon. If you de-select that checkbox, it will work exactly as you've described in your question
    – Clive
    Commented Dec 7, 2012 at 12:09
  • Same comment as the other answer. I'm sorry but I have to check only one answer. I check the fastest one... Thank you very much. Commented Dec 7, 2012 at 12:46
  • No problem, glad you got it sorted :)
    – Clive
    Commented Dec 7, 2012 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.