1

I'm using TinyMCE and I'm using the Full HTML format which shouldn't strip any tags. I copy another web page with an html5 audio tag in it and paste it into the editor. I can see the html5 audio player there, but when I save, it is stripped out.

I tried again and this time brought up the raw html editor and directly put the audio tag into the html. When I click Update, the audio tag is stripped out.

Here is my Full HTML text format config:

enter image description here

  • Did you recently update TinyMCE? There is a bug report about <audio> tags being removed, but it has been closed. The TinyMCE demo doesn't strip them out. – kiamlaluno Dec 10 '12 at 2:23
  • I downloaded TinyMCE 2 days ago, so unless there was a new release today, then I'm up to date. – Kenny Wyland Dec 10 '12 at 4:40
1

You need to deselect "Verify HTML" in the configuration page for the input format using Wysiwyg. Those settings are available in admin/config/content/wysiwyg.

screenshot

Once I disabled that option, I tried with the following HTML, and it worked.

<audio controls>
  <source src="horse.ogg" type="audio/ogg">
  <source src="horse.mp3" type="audio/mp3">
  Your browser does not support the audio tag.
</audio>

option disabled

With that option enabled, this is what I get right after entering the HTML with the HTML button.

option enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.