0

When I go to my database website at kctd.org/community, I get this error:

Fatal error: require_once() [function.require]: Failed opening required '/home/kctd/public_html/community/sites/all/modules/views/modules/translation/views_handler_filter_node_language.inc' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/kctd/public_html/community/includes/bootstrap.inc on line 3069

I have no idea what that means. The last action I did was extending the result of my view filter to include user's email. When I clicked save, this popped up. I cannot log in to even switch to maintenance mode.

What can I do?

  • 1
    It seems like the file views_handler_filter_node_language.inc has moved from modules/views/modules/translation to modules/views/modules/locale. If you flush your cache this should solve your problem. Check out this link: drupal.org/node/1744950 – Cyclonecode Dec 12 '12 at 22:42
  • You should write this up as an answer and include info on how to flush cache on a crashed site thermally bootstrap. – mpdonadio Dec 12 '12 at 23:13
  • clear cache and run cron. – monymirza Dec 13 '12 at 5:10
1

For me it was simply a case of having moved module folders in sites/all/modules to sites/all/modules/CONTRIBUTED - I was trying to clean up my folder structure a bit.

The issue resolved as soon as I moved the module folders back to their original placement.

1

The problem seems to be that views_handler_filter_node_language.inc was moved from views/modules/translation to views/modules/locale. I guess you have updated the views module but not rebuilt you registry. You should be able to solve this by flushing the cache. Here's a issue, addressing the same problem.

Notice that whenever you update a module you should also call the update script located at example.com/update.php.

To flush the cache using drush use the following syntax: drush cc all.

You could also try to clear the cache_bootstrap table using:

mysql -uusername -ppassword -hhostname database -e"DELETE FROM cache_bootstrap WHERE cid='system_list';"` 

or

drush sql-query "DELETE FROM cache_bootstrap WHERE cid='system_list';"

Backup your database before trying the above

If you still have trouble, you could also try to disable the views module using something like this:

mysql -uusername -ppassword -hhostname database -e"UPDATE system SET status='0' WHERE name='views';" 

or

drush dis views

You might need to clear the cache as in the previous step for this to take effect.

Here you can find more information about disabling a module manually: Disabling modules manually in the database

0

I would do two things.

Restart Apache and make sure your APC has enough memory. Errors about require and/or include can be indicative of APC not having enough memory.

If that doesnt fix things, download the registry rebuild module for drush, and run it. Take a database backup first as a precaution.

0
  1. How I got Here; I tried to update some modules using the 'available updates' option in the modules configuration menu

  2. The solution in my own case; First I had to download the following files; views, views_block_area, views_slideshow again which can be found here http://drupalmodules.com/ or https://drupal.org/

  3. Next, I unzipped both files and connected to my host-machine using ftp, then I navigated to ../sites/all/modules and overwrite the directories

  4. further I also made backups of the aforementioned directories in case I may have to roll back configuration

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.