I cannot access the People page. There is no error message. If I click on People in the menu bar, the Administration home page is shown.

screenshot

The other Administration pages are accessible.

screenshot

Similarly, if I click on Permissions for any module, I get the Administration home page; not the Administration > People page.

The User module is enabled. I am logged-in as user #1.

I have checked the .htaccess file and do not see anything that would cause a problem.

I have tried disabling the handful of modules I have added.

What should I do next?

  • 1
    I would check aliases to see if there is an entry for "admin/people" that isn't pointing to where it should be. – donutdan4114 Dec 16 '12 at 5:17
  • OP says he's logged in to user 1. – AyeshK Dec 16 '12 at 13:44
  • 1
    In the URL, if I replace /admin/people with /?q=admin/people, then I CAN access the people page. I found no errors in the access logs. I have not created any aliases. Still searching for where aliases may be lurking. – bigtango Dec 16 '12 at 19:21
  • @bigtango could you edit your last comment into question's body? – Mołot Jun 24 '13 at 6:33

I'm not sure 100% if my solution will solve your issue or not but give it a try

first set base url in settings.php

$base_url = 'http://baseurl.com/Drupal/htdocs';

then check if clean urls enabled from

/?q=admin/config/search/clean-urls

just in case try to clear Drupal cache from

/?q=admin/config/development/performance
  • I have tried a fresh drupal install with no modifications, no additions. Same result, the admin/people page does not display but the ?q=admin/people page does display. The People page is the only Administration page that is not working properly. I have tried editing default.settings.php as well as sites.php. This may have everything to do with this being a temporary development URL. I'll keep trying and post the solution once I find it. – bigtango Dec 17 '12 at 17:45
  • just curious to know if you tried to create content types, views or change any configurations in the config page!! – Aboodred1 Dec 17 '12 at 17:52
  • no, no changes to the config page. – bigtango Dec 26 '12 at 20:03

I had the same error with PHP 7.1. Updated to the latest version of PHP and it worked!

Solution: upgrade your PHP.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.