I'm creating a multilingual website in Drupal 7. I'm using the internationalization and entity translation modules and language detection is set to URL. I use the language switcher (content) from the entity translation module to switch between languages.

Everything works fine as long as I'm logged in as administrator. When I log out, or when I'm just an authenticated user, I can't see the language switcher anymore although the html code is generated. Does anyone what could be the reason for this?

Thank you.

1 Answer 1


You have to check the permissions on internationalization module; probably you have selected "administrator only".

By the way, read this: Drupal multilingual.

  • First of all, thanks for your response. I tried setting every permission that has something to do with translation to enabled for both anonymous and authenticated user, but the language switcher is still invisible when I'm logged out.
    – Smos
    Commented Dec 3, 2012 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.