1

I am using Drupal 7, with VMware 5.0.1 build-894247 with Ubuntu 12.10. 2GB ram, 20GB disk, 32 bit VM, hosted by Windows 7 Enterprise.

I am developing on a team with SVN (subversion) as the source control. All of this works fine on everyone else's (on my team) local dev environment and on our staging/prod servers.

I set up a shared folder from my C: drive on Windows called Sites (C:\Sites), and it appeared as /mnt/hgfs/Sites on Linux.

My dev folder is under that, so /mnt/hgfs/Sites/test.dev

I configured Apache sites-available to point to this new path, and enabled it. I setup the mysql database fresh, and ran through the default install of Drupal. No problems so far. At this point I can log in and out without issue.

When I make a change like importing a theme and setting the theme, then log out, I can no longer log in. The login screen will not even tell me why I am not being logged in (normally there is an error message... it is as if someone disabled java-script or something). If I blow away the database and recreate it, start over with the default install, it works again. My real goal is to enable a backup and restore that to the new site, but that changes the theme and more, and has the same problem (although the theme does change and content is there when I do this... just can't log in)

another kicker, if I move the files back to /var/www/ and re-point apache, it works again. UPDATE: It turns out this problem does not have to do with VMware, as it is now failing in the exact same manner while in /var/www.

I have checked permissions and even set everything to completely unrestricted access (chmod 777 -R).

Any ideas why? This seems very reminiscent of this other post too...

UPDATE: after hours of diagnosis, discovering drush, and playing with variables, my buddy noticed this: If we switch the theme back to Bartik, and login from login, it will fail without even showing an error message. BUT, if we just go to the home page, there is a login block on the left, and if we login there, it works! The top nav bar comes back and everything. Log out and try again from http://sitename/users, and it fails again. He thinks it may be a modules or theme-based permissions issue.

  • for future reference the .../users issue is called "clean URLs", and drupal has a link on this: drupal.org/node/256410 – Watki02 Jan 9 '13 at 6:15
1

Try the following:

  1. check the existence of .htaccess file in Drupal root
  2. truncate the cache tables in the database
  3. check and eventually increase the PHP memory limit in /etc/php5/cli/php.ini
  4. Read and check some other trouble shooting ideas at http://drupal.org/node/158043
| improve this answer | |
  • 1) .htaccess exists. 2) tried clearing all caches with sudo drush cc 3) memory limit is already set to no limit (-1) 4) That's a pretty long link, and it is not exactly a completely white screen (of death), but I will check out some of the possibilities there. Thanks for the tip! – Watki02 Jan 8 '13 at 22:17
1

Wow, so thanks to an experienced Drupal admin, we discovered the issue was in the Apache setup I have. I never enabled mod-rewrite.

The commands to fix this were

sudo a2enmod rewrite

followed by:

sudo service Apache2 reload

sudo service Apache2 restart.

More details:

There is a helpful test for clean URLs in Drupal 7 under <site name>/admin/config/search/clean-urls. This definitively told me that was the problem, then we went back through and tested each required component in my Ubuntu/Apache setup. If you still have issues, check the .htaccess file for configuration and the /etc/apache2/mods-available and /etc/apache2/sites-available. A link that helped me do this was this one: http://www.lavluda.com/2007/07/15/how-to-enable-mod_rewrite-in-apache22-debian/

| improve this answer | |
  • 1
    Note: if you have a problem where Clean URL's are not enabled or configured, and you import a site database where Clean URLs are enabled, you can try to navigate through the admin menu like so: mysite.com/?q=admin/config/settings – David Csonka Jan 10 '13 at 0:17
  • 1
    Thanks for the answer about not having mod-rewrite enabled! I tried to +1 it, but my reputation has not been built on this site yet. - metajunkie – user14571 Mar 12 '13 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.