3

Sorry if I'm using incorrect terms here. What's going on is, when I edit any content, as the the types of content under 'Content Management > Content Type', there's the Image: field, which I think is provided by the CCK Imagefield module or Imagecache. (I'm on 6.x-3.10 of Imagefield)

When I choose a file and click upload, I get a thumbnail image (http:/mysite.com/sites/mysite.com/files/imagefield_thumbs/image.jpg?1357151034). When I click 'Preview', I get a preview with the image I uploaded (http://mysite.com/sites/mysite.com/files/imagecache/product/image.jpg). When I save, the image is gone, and going back to the edit form, it doesn't show up as an attached image. One possible clue; this content type isn't 'product', but it's in sites/mysite.com/files/imagecache/product/.

This all worked until a couple of weeks ago, when I updated a bunch of modules. I did a whole site backup before I ran the updates, and a development version of the site on my local computer doesn't have this problem on up to date modules. The only way I can replicate it on my local machine is to use a backup of the database from after this error occurred.

  • 3
    Are there any File System errors on the Status Report page (admin/reports/status)? What about on the File System Page (admin/settings/file-system)? My guess is that the File System Path is not writeable by the web user, but the Temporary Directory is - and that's why the preview and initial thumbnail work. – Adam Balsam Feb 5 '13 at 15:53
0

Make sure the file directory exists at sites/default/files and make sure it is writeable by the web server. For this you need to go to the file directory if you are familiar with terminal and type chmod -R 775 files when in the directory that contains the file directory. otherwise in an FTP client like Filezilla right click the file and click file permissions and change the permissions there. You may also need to check that this folder files/imagecache/product exists and is writeable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.