I imported a file with 5 fields UPC-> SKU(Unique), Product Description -> Title, Unit Price -> Price Amount and 2 custom fields for wood type and knife number the import process says it created 21 products and I can find these products through phpmyadmin in various places including commerce_product, commerce_product_revision.

There are also a number of entries of type commerce_product in the field_revision_field_product_category table where as the types of my already created content are node in the same table. They all have a price of 0 but are not showing up in the product listing.

I'm using commerce kickstart 2.0, commerce feeds 1.3, feeds 2.0 alpha 7 and have feeds tamper 1.0 beta 4. I have run cron and flushed all caches.

I tried this in a fresh install of Commerce Kickstart but the products are still not showing up in the view products screen.

I also created a barebones Drupal 7 install with commerce and feeds/commerce feeds and other required modules and the products seem to be created just fine.

  • You created products, but no product displays. That's why Kickstart is not showing anything. Kickstart 2.6 now has an "all product variations" view where you can see just the products. – Bojan Zivanovic May 12 '13 at 11:18

Yesterday on #drupal-commerce in IRC, someone had a similar question. It appears that the "title" module may be interfering with commerce_feeds. Try disabling the "title" module and see if that helps your import woes.

  • Still got nada removed tamper module too – mcgyvrfan121 Jan 9 '13 at 0:08

It seems Bojan Zivanovic is right. I don't see anything about a second importer to create the nodes. You'll need two importers and need to specify what gets added to the product (variation) and what gets added to the node (content type).

  • Did you solve this? I guess I must have been unclear as to your question. Does this indicate you did in fact create (and import) to the content type / node: "as the types of my already created content are node in the same table"? If you create a product manually does it show up? Can you confirm your importer settings? – djoyce Jul 12 '13 at 15:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.