1

TinyIMCE is not working: At Hostgator, I cannot access the images that I know are in there (at sites/default/files/field/image and at sites/default/files/pictures). In the text editor, I select the image-add icon (the tree). I select image url icon. The dialog box is limited to showing sites/default/files. It does not allow access to /field/image or /pictures/ The "insert image button at top right is missing (but it exists on my local server.)

I have uninstalled and reinstalled the wysiwyg and imce modules. I have checked permissions. I have made certain the files are in the places noted.

  • maybe suphp is causing the conflict? Have you tried to upload files to your server to discard a permission conflict? hostgator suphp is nobody for this case. – cayerdis Jan 4 '13 at 0:45
  • Can you translate your response to English? What is suphp? I cannot upload image files -- that's part of the problem. What do you mean to say with "hostgator suphp is nobody for this case" ? Is Hostgator part of this problem -- – Kathryn Brewer Jan 4 '13 at 1:34
  • suphp.org/Home.html. suPHP is a tool for executing PHP scripts with the permissions of their owners, Hostgator uses it. Hostgator explains here that they use suphp support.hostgator.com/articles/phpsuexec-or-suphp – cayerdis Jan 4 '13 at 2:12
0

Perhaps you'd prefer the Insert module. Demo here.

Simply upload an image and click the "Insert" button to insert into the textarea.

You can also select from available image styles on insert, e.g thumbnail, large etc..

After installing, you'll need to add an image field to the content type and configure Insert on that field settings page.

Added bonus is uploaded images use the Drupal files API and are therefore, among other things, available for display elsewhere on the site, e.g with Views, which isn't possible with IMCE.

0

I believe the image component of TinyMCE is a licensed product you have to buy, see http://www.tinymce.com/download/download.php at bottom. You might want to try IMCE module http://drupal.org/project/imce which is free and integrates nicely with the WYSIWIG interface. If you do decide to go that route, afteryou install IMCE make sure you turn on the check box for IMCE in the TinyMCE options inside the WYSIWIG Admin Tab in Admin -> Configuration. Works like a charm for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.