I am trying to upgrade Drupal from 7.14 to 7.18 using drush up command.

Nothing gets updated and I see a bunch of failed warnings:

Failed to check available update data for CCK.
Failed to check available update data for CKEditor.  
Failed to get available update data for 51 projects.

I can however download modules using drush dl module_name All commands are run as root.

  • any useful error messages from drush up -d (-d is for debug)?
    – tenken
    Jan 9, 2013 at 22:56
  • Is Update module enabled? Are there any strange errors in Status Report, like HTTP Requests failing? Jan 10, 2013 at 0:13

1 Answer 1


As tenken suggested, you might try adding -d for debug to your drush command or -v for verbose.

Beyond that, I suggest trying to set $conf['update_max_fetch_time'] to a higher value (I usually set it to 360). It sounds like you may be running into an issue where fetching the update information is exceeding the timeout.

  • I dont have FTP access my my server, I do everything using SSH. I increased the timeout from 5 to 360 seconds as recommended in modules/update/update.module as well as drush vset update_max_fetch_time 360. Next I ran drush up -d but I still get warning, here a pastie: pastebin.com/raw.php?i=wZzdYp1d
    – Ura
    Jan 10, 2013 at 15:06
  • Your paste makes it look like your Drupal site is unable to connect to the update server on Drupal.org - see where the paste starts saying "Failed to check available update data " for every module. Try checking direct access from your server to eg updates.drupal.org/release-history/drupal/7.x via curl or wget. Feb 13, 2014 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.