1

Hello i have some nodes which i am using as to hold information on a taxonomy term (image, desc etc) and I have created some block views to pull that information to display on my taxonomy/term pages (yes om on D6 due to custom modules and upgrade problems)

Also ive made the term nodes appear on the parents term page in a node view.

  • Sport
  • -American Sports
  • --Baseball
  • --NFL
  • -Football
  • --England (etc)

This is in a View with tax depth of -1 (just show the immediate children) If i visit 'Sport' I only see my 'Sport' stuff and then below in the child term (node) View i see

  • American Sports
  • Football

Well in an ideal world thats all i see but because i am in 'Sport' I also see the node for the 'Sport' term that i am in.

  • Sport
  • American Sports
  • Football

I want the -1 in depth but i dont want the '0' if that makes sense.

I have tried excluding the argument, like you do for for nodes with nid but it doesnt seem to work the same.

Its the same all the way down. If i go into 'American Sports' in my list of nodes that are referance (like that old drupal video from Bob (the christian) 'taxonomy on steroids) shows as-

  • American Sports
  • Baseball
  • NFL

etc.

Aye so in a round about way i was wondering how to exclude...no how to only display, nodes of child terms (-1)

All help appreciated as its been annoying me for a while and ive been trying to sort it for ages.

thanks

1 Answer 1

2

You could add an Node Nid as argument and check "Exclude the argument"

Select "Provide default argument" and select "Taxonomy Term ID from URL"

And then check "Load default argument from term page"

Thank should work for you.

Let me know if that helps.

16
  • Nah it doesnt seem to like that either Shameem but thaks for the suggestion. I tried that earlier, and again there. The node for 'science' still appears on the 'science tax page' along with child term nodes ('nanotechnology', 'physics' etc). I have my site turned off to the public today till i finish it so i cant even let folks see what i mean. here's a screenshot if it helps anyone s9.postimage.org/k8buzxvnj/olbprob.jpg
    – Reg Gordon
    Jan 16, 2013 at 7:07
  • Are you passing the term ID or Term name to the page? Or have you aliased the path to taxonomy term page? And why the use of -1 instead of depth 1 if you are looking to show the child nodes. If possible could you send me a screen shot of the views configuration page you are using Jan 16, 2013 at 7:11
  • Thaks Shameem. Here is a picture of my view (Views 3) s2.postimage.org/x60ev7lsp/blockview.jpg The node argument i added since we spoke and ive had it before and after the tax argument. The view is here - pastebin.com/ADTxw73s All works as hoped just i dont want to show level 0 items. Ive tried various filters on the views but the problem is i want 'football' to still appear under 'sport' and its all using the same view. If i could only show nodes of child terms of the term being viewed then that would solve everything i think.
    – Reg Gordon
    Jan 16, 2013 at 7:40
  • could you take a screen shot of both the configurations for node id argument and the taxonomy id argument. (Kind of lazy to go through the views export code :-) ) Jan 16, 2013 at 7:52
  • No your alright Shameem i appreciate your knowledge so anything i can do :) Here is my tax argument (which brings in the 'tag' nodes for 0 and +1 terms) s9.postimage.org/ra1zgrzb3/tax_arg.gif and my new nid argument s13.postimage.org/637m687o7/nid.gif thanks
    – Reg Gordon
    Jan 16, 2013 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.