I have a view that is sorted by the number of times a user visits a node and clicks the play button (the play button is a menu item of the node). Every time the play button has pressed the value of an integer field inside the node is incremented and this value is used to sort my view. I also display the value "Times Played" both in the view and the node. When I look at the view as admin everything looks good, like this:

enter image description here

But when I look at the view as a normal user the view is still sorted correctly but some of the nodes don't show the value for "Times Played", here is that screenshot: enter image description here

Also, when I view the actual node page as an admin I see always see the correct value for "Times Played" but when I visited it as a normal user I get the same behavior I see in the view. Any idea what could be going on here? Is this some strange permissions issue?

  • what happens when you add another simple text field to the content-type? Does that show up in all the instances in both the view and node page?
    – devunder
    Jan 18, 2013 at 23:25
  • Yes if I add a static integer field that is only set once (when the node is created). It shows up in both the view and the node page, for both standard and admin users.
    – Mike2012
    Jan 18, 2013 at 23:44
  • are all the nodes of the same type? or is the issue with a specific node type? Jan 19, 2013 at 5:49
  • 2
    @Mike2012 What is the markup when the field is displayed and when it's empty? Did you check Drupal log (like dblog)? Mar 22, 2016 at 15:10
  • 1
    @Mike2012, what if you run the query with Advanced>Other>Query Settings, try checking Disable SQL rewriting
    – Justme
    Aug 21, 2016 at 8:00

2 Answers 2


Did you try to embed view in your template file? $embed = views_embed_view('name_of_view','display_id'); . You need also to check permissions


In the query options of the view disable SQL rewriting and see what happens. If your fields appear again for all the users then you have some kind of restriction at field level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.