1

I am using Panels and have enabled the Panels In-Place Editor module but cannot see the edit icon on the page, the one that should be in top rhs corner.

What am I doing wrong?

  • Did you clear the cache? – Patrick Kenny Jan 19 '13 at 6:54
  • Thanks. Just cleared the cache but still not seeing the contextual edit tags or whatever they are called. – user12804 Jan 19 '13 at 7:58
1

you need to select the Renderer mode:

Standard or In-Place Editor

Standard Renders a panel normally. This is the most common option. In-Place Editor Allows privileged users to update and rearrange the content while viewing this panel.

| improve this answer | |
0

I think you mean the little gear icon that allows you to edit fields (Panes) in a panelized page?

That would be FAPE, the Fields API Pane Editor. It should be part of ctools, but is a separate module.

Yes, In-Place Editor sounds like it would edit content, but it works on the panels layouts.

| improve this answer | |
0

In addition to enabling the "Use the Panels In-Place Editor" permission for your desired role, ensure that the "Use Page Manager" is checked.

Before I enabled the "Use Page Manager" permission the gear would actually appear for block and node areas, but it wouldn't appear for the entire Panels page. Enabling the "Use Page Manager" allowed the gear icon to appear for Panels areas as well.

| improve this answer | |
  • Where do you apply this option?... – user16289 Apr 24 '15 at 20:36
  • @ben /admin/people/permissions – emc Apr 24 '15 at 22:10
-1

You need to see the permissions of the use "in place editor."

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.