0

I enabled the Bartik theme and made it the default, but the home page of the site, or any other pages I add, do not have the theme applied to them. The most noticeable difference is that the regions do not have any background colours that the Bartik theme is meant to define.

I tried clearing the cache and using a different browser. i'm new to Drupal, but have tried reading the documentation and this just gives the impression that once you enable a theme and make it the default, it should apply to your pages.

Here's a screenshot of the top of the home page:

enter image description here

and here's what the Bartik theme is meant to look like:

enter image description here

  • 2
    two files sites/default/files/color/bartik-5a6281f2/colors.css and sites/default/files/color/bartik-5a6281f2/logo.png are giving internal server error you should check if there is any issue permission issue with the files folder... – Mohammed Shameem Jan 19 '13 at 15:57
  • This happens when the web server either 1. cannot write to the tmp folder set in the admin interface or 2. cannot write to the default files folder (usually sites/default/files) – Clive Jan 19 '13 at 17:00
  • Thanks Mohammed - that was a great clue. I was able to see the loading errors using Chrome's developer tools. The problem turned out to be the .htaccess file installed by Freehostia. It contained instructions which contravened Freehostia's security policy and which needed commenting out: #Options None #Options +FollowSymLinks. (Sorry about the formatting - Markdown doesn't seem to be working properly in comments.) – Glyn Normington Jan 21 '13 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.