1

It turned out there were two issues here: first checkout stopped working, then the server ran out of space. I now have space on the server, but the checkout still isn't working.

It's a commerce site, and checkout worked fine until launch and now the process appears to be broken. I get this message in the Drupal error log.

Notice: Undefined index: field_extra_instructions in commerce_customer_profile_pane_checkout_form() (line 165 of /home/wholebox.org/www/profiles/commerce_kickstart/modules/contrib/commerce/modules/customer/includes/commerce_customer.checkout_pane.inc).

The site is wholebox.org and if anyone can help find out what's wrong, it would be very handy right now.

Could I have disabled an important module when trying to make it faster?

closed as too broad by kiamlaluno Dec 15 '17 at 19:02

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • It could be a 403 page- but now my 403 report page is displaying an error - file could not be created – ankles Jan 21 '13 at 17:51
  • I don't see any error. Do you have any error message or behaviour. Take a look in the log messages in admin/reports/dblog. – cayerdis Jan 21 '13 at 17:52
  • take a look in your temp folder permissions setting.. and make sure that the path is correct. More info drupal.stackexchange.com/questions/30113/… – cayerdis Jan 21 '13 at 17:54
  • added a php error... – ankles Jan 21 '13 at 17:57
  • 1
    Disk space issue resolved -server admin sorted it. But checkout still broken... I get this... Notice: Undefined index: field_extra_instructions in commerce_customer_profile_pane_checkout_form() (line 165 of /home/wholebox.org/www/profiles/commerce_kickstart/modules/contrib/commerce/modules/customer/includes/commerce_customer.checkout_pane.inc). – ankles Jan 21 '13 at 18:20
1

Checkout problem - there are two possibilities that fixed it, as I re-enabled Extra Panes and Coupon UI at the same time.

I had set an extra field in Customer Shipping Profile. I didn't think it was dependent on Commerce Extra Panes, but when I disabled that module the process broke.

It could also be that the coupon UI module provides the text box on the checkout process, so when I disabled that it broke it.

Thanks for everyone's help in the comments above :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.