2

I've got CKEditor and IMCE modules installed and enabled. I've got an "Insert image" link at the bottom of the "body" text area. However, I can't seem to get the wysiwyg editor to display.

What am I missing?

In admin/config/content/formats I only have Plain text format.

Should I add Fitered HTML, full HTML and php manually?

Or shoud have they been created automatically with one of the modules?

  • Have you selected the correct filter. depending on your settings wysiwyg would be enabled for some of the filters only. may be just for the Full HTML – Mohammed Shameem Jan 22 '13 at 4:51
  • Thanks. But I don't even get that dropdown menu where I can select between full/filtered/plain html or whatever. All I see is this: Insert image or link. More information about text formats No HTML tags allowed. Web page addresses and e-mail addresses turn into links automatically. Lines and paragraphs break automatically. – kine456 Jan 22 '13 at 5:21
  • could you take a screenshot and send it. – Mohammed Shameem Jan 22 '13 at 5:24
  • How do I attach files? – kine456 Jan 22 '13 at 5:33
  • You can upload them with Skitch and link them if you do not yet have permissions to attach them to your posts here. – beth Jan 22 '13 at 15:51
5

Depending on what version of Drupal you're using, my first inclination is to say the Media module is what you're missing.

That aside, there are a number of steps to take to configure the WYSIWYG image experience.

  • How did you install CKEditor? Did you install the WYSIWYG module and the CKEditor library properly?
  • Did you install the correct version of CKEditor? I think you might need the 3.6 version.
  • Have you set up the correct input format? Does your user have permissions to use it?
  • Have you set up a CKEditor profile with the correct image insert buttons that integrate with IMCE?

Those are the main things that come to mind, though knowing more about what happens (i.e., when you disable rich text, does anything display in the editing window?) and what steps you've already taken would help narrow it down.

  • Thank you Beth I am using IMCE instead of the CKEditor Library. – kine456 Jan 22 '13 at 5:31
  • I think beth has covered most of the things that you should check. For more help it would be good to get some more info from you. You can attach the image to your question rather than the comment – Mohammed Shameem Jan 22 '13 at 5:35
  • How do I attach images? I just installed the media module but still no luck. I've got ckeditor, wysiwyg, imce, media modules enables. They are all in the modules directory. I've got the same structure on another site and the editor works fine... – kine456 Jan 22 '13 at 5:39
  • In admin/config/content/ckeditor/edit/Advanced Under Basic setup - Text formats I only have one option, which is Plain text. However, on the site which does display the ckeditor correctly I've got the following options: Filtered HTML Plain text PHP code Why would this be the case? – kine456 Jan 22 '13 at 6:04
  • In admin/config/content/formats I only have Plain text format. Should I add Fitered HTML, full HTML and php manually? Or shoud have they been created automatically with one of the modules? – kine456 Jan 22 '13 at 6:07
2

In my case there was some error on javascript side. When I started debuging using Firebug, then I got exact the line number with error and commented out the line. This solve my issue and all button appear in IMCE File browser.

I am using Wyswing. module , IMCE and Wysysing IMCE Bridge module in Drupal 7

ANOTHER POSSIABLE REASON IS : YOU MAY HAVE NOT ASSIGNED THE USER PROFILE OF IMCE TO ROLE. 1) GO TO admin/config/media/imce 2) ASSIGN EACH ROLE A USER PROFILE USER-1 3) AND SAVE.

0

I found that the sharebar module conflicts with the imce / ckeditor

https://drupal.org/project/sharebar

there is even a open issue for this. https://drupal.org/node/2058939

once I turn off sharebar module, imce image upload buttons reappear.

0

An old problem, but still relevant ;-) In my case it was a jquery incompatability issue with bootstrap. Enabling Jquery update module was the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.