3

This question is an exact duplicate of:

I have a view, format: table; and a few fields:

  1. Bulk operations: Content
  2. Content: Title
  3. Content: Price
  4. Content: Stock 1 (Stock 1)
  5. Content: Stock 2 (Stock 2)
  6. Content: Stock 3 (Stock 3)
  7. Global: Math expression (Total Stock)
  8. Global: Math expression (Total Price)

At Configure field: Bulk operations: Content section SELECTED BULK OPERATIONS i selected Delete item and another 3 options (rules components). These are: new_value_for_stock_1, new_value_for_stock_2, new_value_for_stock_3, new_value_for_price.

Admin user can see all these options (rules components), but a non-admin user (eg. an editor role) can see only Delete item.

Is there a method (trick) to give permissions for a non-admin user (role)?

I enabled Actions permissions (VBO) and in Administration » People » Permissions are displayed only default actions (eg. EXECUTE Delete item). The custom rules components aren' displayed there.

marked as duplicate by Pierre.Vriens, mradcliffe, DRUPWAY, Chapabu, sanzante Aug 29 '17 at 11:32

This question was marked as an exact duplicate of an existing question.

  • If you give 'Bypass content access control' permission to a non-admin user, he'll be able to see these custom rules components. – Ionut Adrian Luchian Jan 29 '13 at 7:57
  • 1
    Granting the above permission is very dangerous as allows unrestricted access to add/edit/delete content ^ You just need to check the "Configure access for using this component with a permission" as milkovsky answered below. – David Thomas Feb 2 '14 at 22:33
3

You can set permissions on rule component page in fieldset at the page bottom.

There is an option "Configure access for using this component with a permission."

Not the answer you're looking for? Browse other questions tagged or ask your own question.