0

I am using a zen subtheme and a superfish menu. I am trying to override the background colours of the menu but am not having luck in IE8. I've tried clearing the cache but still no luck.

Do you have any idea why? Why isn't IE8 recognising the pages.css style sheet?

This style sheet is being picked up by IE8.

superfish/style/default.css

.sf-menu.sf-style-default li,
.sf-menu.sf-style-default.sf-navbar {
  background: red;
}

.sf-menu.sf-style-default li li {
  background: pink;
}

.sf-menu.sf-style-default li:hover,
.sf-menu.sf-style-default li.sfHover,
.sf-menu.sf-style-default a:focus,
.sf-menu.sf-style-default a:hover,
.sf-menu.sf-style-default a:active {
  background: green;
  outline: 0;
}

While this style sheet is being picked up by FireFox (this is what I want).

mytheme/css/pages.css

.sf-menu.sf-style-default li,
.sf-menu.sf-style-default.sf-navbar {
  background: orange;
}

.sf-menu.sf-style-default li li {
  background: yellow;
}

.sf-menu.sf-style-default li:hover,
.sf-menu.sf-style-default li.sfHover,
.sf-menu.sf-style-default a:focus,
.sf-menu.sf-style-default a:hover,
.sf-menu.sf-style-default a:active {
  background: grey;
  outline: 0;
}
  • version D6 or D7?? – monymirza Jan 24 '13 at 5:05
1

It was just a matter of selection the Aggregate and compress CSS files option under Bandwidth optimization

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.