0

Noticed I am auto logged out or at least that is how it appears with the admin bar disappearing and login form visible when I hit the home link.

If I go from logged out home page to another page I appear logged back in.

I am on drupal 7.19 and it resides in a folder set up as a subdirectory.

drupal.mysite.com

the folder is at drupal.mysite.com/drupal

This only occurs when I am navigating about without www prefix and does NOT happen when navigating about with www prefix. My site can be accessed either way but currently advertising as without prefix. The www is more secure obviously but need both to work.

  • Have you checked the .htaccess settings? – Patrick Kenny Jan 25 '13 at 4:47
  • my .htaccess had to be removed because it interferes with clean urls. Instead I use httpd.conf and settings.php but you are right I think. But don't want to choose between prefix or not, both should work. – Ann Jan 25 '13 at 4:49
  • In that case, this is very likely a problem with the configuration in your httpd.conf and settings.php. If your hosting provider offers Drupal hosting, I would ask them first about what may be the problem; as the provider, they know your set up much better than anyone else. – Patrick Kenny Jan 25 '13 at 4:54
  • I am not sure why .htaccess would interfere with clean url. it is meant for that. – Mohammed Shameem Jan 25 '13 at 6:02
  • Well .htaccess uses more memory to run and the httpd.conf together with settings and php.ini can do the work between them. But the .htaccess code for prefix or no prefix with www is an either or statement so not code that I can use even tho could use if i wanted added to settings file. – Ann Jan 25 '13 at 10:53
0

Answer is well stated here http://drupal.org/node/110478

Had I spent a little more time reading I would not have had to ask this question. Also I can see now it is making it so no matter which prefix you use the cookie will stick.

  • actually no , in the end this was all about the browser not being up to date in safari. – Ann Jan 28 '13 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.