1

Here is what the bottom of my "leaflet" content type edit form (i.e. admin > structure > content types > leaflet > edit) looks like: Leaflet content type edit form

Here is what the bottom of my "testimony" content type edit form looks like: enter image description here

Note that there are no save/delete buttons! Another of my content types has also now picked up this bug. This just happened. I have no idea why. I can't save changes! I tried flushing all caches and it didn't help. I'm an administrator and I have permissions for everything.

Why would this have happened and what can I do? Drupal 7.19.

  • Try disabling Diff, i18n and other modules that might be altering this form (modules that likely adding new elements to this form). there could be a module altering the form improperly. – AyeshK Jan 29 '13 at 22:05
2

The problem was the i18n synchronize translations module. Disabling it fixed the problem. Of I have to immediately re-enable it afterwards since I actually use this module. So I filed an issue: http://drupal.org/node/2004260. Thanks to Ayesh K who gave me the idea in his comment on my question. Since it's not an answer I can't mark it correct, so I'm just answering here and will mark this correct.

|improve this answer|||||
1

Looks like an odd one, some form_alter or theme issue.

If you try a good admin theme like

  • Tao ( base admin theme )
  • Rubik ( admin theme )

Download both, enable and set admin theme in

  • /admin/appearance
  • ADMINISTRATION THEME Choose "Default theme" to always use the same theme as the rest of the site. ( RUBIK )
  • Use the administration theme when editing or creating content ( CHECK )

The buttons should show up again

|improve this answer|||||
0

Check in your content type, you probably selected require preview before publishing.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.