0

I've downloaded and enabled the css3pie and libraries modules, and downloaded and extracted the PIE Library to sites/all/libraries/PIE

I initially tried adding the css selectors to admin/config/user-interface/css3pie but because that wasn't working I've now added them in my mysite.info: settings[css3pie][selectors][] = "#block-block-1" settings[css3pie][selectors][] = "#block-block-8"

In my css file C:\Projects\mysite\sites\all\themes\mysite\css\layout.css I've put the following:

block-block-1, #block-block-8 {

background: red;
padding: 2em;
-moz-border-radius: 1em;
-webkit-border-radius: 1em;
border-radius: 1em;
behavior: url(C:/Projects/mysite/sites/all/libraries/PIE/PIE.htc);

}

The PIE libraries is here: C:\Projects\mysite\sites\all\libraries\PIE\PIE.htc

What am I missing and doing wrong?

I have a feeling I've got the path wrong :(

Of course you will need to adjust the path to match where you uploaded PIE.htc in step 2. Note: this path is relative to the HTML file being viewed, not the CSS file it is called from.

How do I reference the path correctly?

0

The PIE Drupal module should add the behaviour where necessary, you don't do that yourself. This would defeat the point of the Drupal module, and in using the Drupal module you don't need to specify the path yourself. (Though your current path there is incorrect, but I'm not sure on the correct way right now.)

css3pie can seem very touchy, there is a long list of known issues, some of which could be causing your problem. Also ensure that your files directory is writable, and that there are no errors on your sites status page. File permission problems can prevent the css3pie module from creating it's stylesheet. Each setting in the themes .info file should also be on a new line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.