0

Every time I add a new field to a taxonomy or any Content type, I get this error message on the edit screen.

Notice: Undefined index: default_image in image_field_update_field() (line 439 of /var/www/html/modules/image/image.module). Notice: Undefined index: default_image in image_field_update_field() (line 439 of /var/www/html/modules/image/image.module).

I'm stuck on where to debug next. Drupal logs show this message? Other image related modules include BackgroundField. Has anyone come across this?

1

Sounds like an issue with your current Drupal version

A patch to fix this has been committed to 7.x and will be available in 7.15. In the meantime, visiting the image field settings form and clicking Save will resolve the issue

More info: http://drupal.org/node/1558548
Patch here: http://drupal.org/files/drupal-1558548-3.patch

  • Thank you. I'm still working on a development install for this project. Knowing a fix is coming down is comforting. – Rick Jan 31 '13 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.