0

Here's what I did

  • I have working content pages I like
  • I want to have the latest of these display as the front page of my site
  • When that node displays as the front page, I'd like a few additional blocks to display. This was easy to solve by configuring the blocks to only show on <front>
  • I built a view to show the latest page, creating a "node page" display, with "single node" as the style (from Top Node module). I sort by Node: post date. I give it the path "latest"
  • I set "latest" as the front page of my site.
  • The front page now goes to the latest node, but the front page only blocks do not display. When I check the source, the body tag does have class "front", but the blocks aren't showing. I tried setting the block configuration to show on page "latest", but that didn't work either.

How do I get the blocks to show? I don't want to build an all new front page using views because I have some programatic things in my template.

  • You set the site frontpage on configuration > site information, correct? Did you clear cache? What happens if you change the blocks to show on 'latest' instead of '<front>'? – beth Jan 31 '13 at 15:57
  • I did try changing the block. Didn't work. The more I look into it, it may be a peculiarity of the Top Node module. – Fadecomic Jan 31 '13 at 16:00
  • Note, instead of a view, you could also set the site frontpage to a node path, that way <front> should still work for the block visibility – David Thomas Jan 31 '13 at 22:01
  • <front> should work for a view too. It will work for any path you assign as the home page on the site information admin settings page. Something else must be the problem. – rooby Feb 3 '13 at 11:41
0

My problem appeared to be with the Top Node module. Apparently, the views display it introduces redirects in a way that causes the <front> tag not to work as it should. The answer is actually quite simple, and honestly makes the Top Node module seem a bit redundant. Although it's not intuitive to me, under "Row Style" on views, you can specify full node content, which, as the name implies, renders node results as they would appear if you typed in the URL directly. I simply made a view that returned one result, Row Style set to full node, and then created a page display at the URL "latest". Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.