8

Suddenly my drush has switched language and displays error messages in my native language, which is unfortunately not convenient if one tries to search for solutions on these errors.

Do you know how to switch the language of drush errors back to English?

2 Answers 2

4

Adding the following string to drushrc.php worked for me with Drush 5.4:

$options['variables']['language_default']->language = 'en';

In my setup I placed drushrc.php into sites/default/drushrc.php, for other possible locations see documentation in examples/example.drushrc.php in Drush installation directory.

1
  • This works for me, whereas the solution by schnippy does not.
    – donquixote
    Jan 25, 2016 at 17:15
3

Create (or modify) your drushrc.php file and add an option for your default language:

$override = array(
  'language_default' => (object) array(
    'language' => 'en',
  ),
);
2
  • Unfortunately, putting that in ~/.drush/drushrc.php did not solve the problem. I still get localized errors.
    – lefterav
    Feb 7, 2013 at 1:24
  • did you try a 'drush cache-clear' command after updating the drushrc.php file?
    – schnippy
    Feb 10, 2013 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.