2

I designed and set up a site for a client at Gregory Lamberson.com, and for some reason when he tries to create new content, the images are not uploading to the correct directory. The old images that I put on the site are showing up fine at /sites/default/files, but when he tries to add a new image, it writes the image into /?q=sites/default/files, and that directory doesn't exist, so the images are not showing up into the site.

Clean URLs are not enabled, so I was thinking that if I do enable them it might solve the problem. However, I am just starting out in front-end development and I could use a second (professional) opinion.

The nodes in question are in Storm Demon & AfterLife Project.

Thanks!

  • Consider choosing the correct answer by clicking the tick icon on the left of your answer. – niksmac Feb 4 '13 at 4:20
4

I fixed this problem. Apparently it was a permissions issue with the default directory. I set it recursively to 777 and the client was able to post images without a problem. I just had to make sure to reset the permissions on the settings.php file.

1

777 grants full access for anyone to write and execute files on your server! I know 777 makes everything work, but you'll be happy until someone hacks your server.

Use CHMOD instead and apply the server username. Once you transfer from local to remote, the ownership is carried over if you use a tarball and that can cause this issue. 770 would be much better than 777.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.