1

I have installed drush on crunchbang linux and while most of the drush commands are working, I can't get core-cli to work. Typing drush @dev core-cli produces:

The drush command 'core-cli' could not be found. Run[error] drush cache-clear drush to clear the commandfile cache if you have installed new extensions.

I initially tried installing drush via apt-get, but when core-cli didn't work I tried getting it via pear, but it's doing the same thing. With the version I got from pear - which is 5.8 - the command drush self-update works, where it didn't in the apt-get version, which was an earlier release.

I've made sure that my user has full rights to the /usr/share/php/drush folder.

Please let me know if you have any suggestions on getting core-cli to work on crunchbang (debian).

  • Are you sure that drush core-cli exists? If yes, what does it do and from where did you get that command? Is there any module that provides that drush command? – subhojit777 Feb 3 '13 at 17:33
2

drush core-cli has been removed in Drush 5

Drush 5 supports bash completion which is much more native and superior to the old core-cli command, which has been removed.

More information: Core-cli command removed in favor of Bash completion

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.