10

Options aren't working in my views UI. JavaScript is enabled. Example, if in views, if I want to re-write output, and I click the checkbox, I don't get more options.

  • check your error logs in apache, is your views module hacked or "modified"? – saadlulu Feb 6 '13 at 7:04
  • No. Views looks fine. – vintorg Feb 6 '13 at 7:12
  • Try clearing the browser cache, and also make sure "firebug" or any other developer tool isn't running on the site. – AjitS Feb 6 '13 at 7:14
  • Tried that. Still not working. – vintorg Feb 6 '13 at 7:20
  • @vintorg, Can you please attach a screen shot? – Sithu Feb 6 '13 at 7:20
23

I just had a similar issue (June 2014) with Views UI. The ajax interactions on the 'style settings' simply stopped working so click on 'customize field HTML' and nothing happened. Hence finding this post/tip. I went to the Modules/JQuery configurations screen (http://website.co.uk/#overlay=admin/config/development/jquery_update) and instructed the Admin Pages to use JQuery v 1.5 (instead of the current 1.10). All View UI interactions then worked fine again.

Adding this extra note for anyone that might find that handy. Thanks to Vintorg and other repliers for the solution.

Q.

| improve this answer | |
  • 3
    Working also with jQuery v1.7 and v1.8 – sobi3ch Jan 3 '15 at 21:46
4

Mystery solved. It looks like a conflict with what version of jQuery I'm using. On the site that isn't working, I have jQuery update set to 1.7 (which the slider depends on). The site that works didn't have jQuery updater, and seems to be running v1.4. So, I dropped the version of jQuery from 1.7 to 1.5, and views is back to normal (but, of course, the slider doesn't work).

| improve this answer | |
  • 1
    keep default version to your required one and change version to 1.5 for administrative pages which is optional in jQuery update configuration page. – Janaka R Rajapaksha Jan 16 '15 at 7:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.