7

I would like to load my own, but Drupal seems to forcefully load it's own by default behind the scenes.

8

Turned out to be as simple as placing favicon.ico into the theme root folder (!)

3
  • 1
    That's the harder way to do it but it works Jul 3 '11 at 5:40
  • It will work for old IE browsers, I assume, since other browsers follow favicon rule on html page..
    – Nikit
    Nov 13 '14 at 0:15
  • To clarify— Placing the favicon.ico in the root of the theme folder, presuming you are using a custom theme, is by far the easiest way to tell Drupal to use that favicon.ico file in the rel favicon tag (otherwise it will use the Druplicon from core). This is separate from putting a favicon in teh root of the web directory for old IE browsers and such.
    – mlncn
    Jul 15 '16 at 14:05
6

http://YOURSITE/admin/build/themes/settings - upload your favicon for all enabled themes, as for "Global settings".

2
  • 1
    This doesn't seem to work in Drupal 7. Nov 12 '14 at 22:55
  • It works, but browsers hardly cache favicon, try clear or on other browser.
    – Nikit
    Nov 13 '14 at 0:22
5

In Drupal 7 there's a way that's easier than loading the image file to a particular directory and you get some error checking. There's a global admin page that allows you to upload in icon image. Log in as an administrator and visit

http://www.EXAMPLE.com/#overlay=admin/appearance/settings

Look near the bottom of the page for the "Shortcut Icon Settings". You can turn on/off the default, set a path to a file and upload images.

Each theme has a similar setting that overrides the global setting. Be aware that changing the global setting my not work as you expect for a changed theme.

-Bob

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.