0

I am creating a dev site from production and I read the migration guide and it's basically -- export database, rsync files. So, I cleared the cache (drush cc all) and also turned off Clean URLS because that was suggested in the guide.

I then proceeded to export the database & web directory & files... structure originally;

/home/drupal
/home/drupalfiles
MySQL DB

I decided to change the locations...

/var/www/html/drupal
/var/www/html/drupalfiles

However, all the images are now displaying with an 'x'. When I right click on the image, it says it's looking for files in /system/files ... which, I have a symbolic link in /sites/default/all for files to drupal_files (which wasn't needed on production, btw). Even then, I don't know why it's trying to look in a directory called system.

The file-system settings is listed as 'files' on production and dev. So, I have no idea what's going on :( .. in the database, files are listed as /files/.

So frustrating :(! Any help would be appreciated.

0

If you're using symlinks, you'll have to allow that in your .htaccess file.

  • even though it's the wrong answer, I will edit it to LOOK like an answer. – jdu Feb 8 '13 at 20:45
  • And I'll adjust my response to say; FollowSymLinks is indeed enabled in the .htaccess file. – Ethabelle Feb 8 '13 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.