2

On a Drupal 7 multilingual site, I have a content type containing a field_group containing itself entity references fields.

I haven't enabled the i18n submodule "Synchronize translations" ("i18n_sync").

I have a content in French:

  • contentFR

    • entityreferenceFR 1

    • entityreferenceFR 2

I want to translate this content in Italian, so I translate the entity references first, like this :

  • entityreferenceIT 1 (translation of entityreferenceFR 1)
  • entityreferenceIT 2 (translation of entityreferenceFR 2)

Then, I translate "contentFR" in Italian, and associate my 2 Italian entityreferences to this new Italian content, like this:

  • contentIT (translation of contentFR)

    • entityreferenceIT 1

    • entityreferenceIT 2

Everything seems to go perfectly well, except that, when I go back to my French content, the references are the italian ones, like this:

  • contentFR

    • entityreferenceIT 1

    • entityreferenceIT 2

If I edit again the French content to set the French references instead of the Italian ones, the switch happens again in the other way:

  • contentIT

    • entityreferenceFR 1

    • entityreferenceFR 2

This is a live production site with 5 enabled languages. We've just enabled Italian and the issue exists only since then. Before, with other languages, everything was working well; the entity references were not linked to a wrong referent.

Also, I've seen this quite similar thread (Node translation syncing problem with entity references) but:

  • In my case, there's no synchronizing set on the reference field
  • There wasn't any answer given in the original thread

The enabled i18 modules are: Block languages, Multilingual content, Multilingual select, Path translation, String translation, Taxonomy translation, Translation redirect, Translation sets, and Variable translation. The disabled modules are: Field translation and Synchronize translations.

Do you have any idea why this happens?

1

I guess you need to enable entity translation for this field; it can be done in the field UI, after installing the Entity Translation module.

  • Thank you but that's not what I want. I don't want per-field translation. I want my contents to be as independant as possible. – claire_ Feb 27 '13 at 10:47
  • Are you sure i18n_contrib isn't enabled as well? – TwoD May 31 '14 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.