0

I have a tab in mysite.com/user called "Evaluaciones" but I don't know why is there. The link for this tab is user/1/webform-submissions-por-user then I guess it is generated by the webform module, but I already disabled this module and the tab is stil there.

How can I trace it? How Can I remove it?

enter image description here

  • Are you 100% sure you disabled the Webform module (and not one of it's sub-modules maybe)? It doesn't make sense that a tab provided by a disabled module would show up, unless you have some aggressive cache happening somewhere? Or maybe grep your codebase for webform-submissions-por-user and see if it's something in custom code... – Clive Feb 19 '13 at 14:06
  • Yes I am. I did it with drush. I disabled webform and all modules that depends on webform module. The tab is still there. I think it has to be another module which is using the same name for the path – chefnelone Feb 20 '13 at 9:54
1

You can use Tab Tammer module to hide it.

Tab Tamer is an administration utility that provides easy re-ordering, hiding, and deactivation of tabs and subtabs. You can also rename tab labels.

  • 2
    This will not address any permission problems if you are trying to remove the functionality from the user. The user could still manually goto the URL. – iLLin Feb 19 '13 at 14:00
2

Its coming from the webform module. I believe if you turn off the ability to allow users to view previous submissions it will go away.

  • I'm 100% sure webform and its permissions are disabled. – chefnelone Feb 20 '13 at 9:49
1

You can hide using hook_menu_alter() hook.

function menualter_menu_alter(&$items) {
unset($items['user/%user/webform-submissions-por-user']);
}
  • I just created the hook: 'function utilities_menu_alter(&$items) { unset($items['user/%user/webform-submissions-por-user']); }' but the tab is still there. The full path of the link is 'localhost/mysite/user/1/webform-submissions-por-user' – chefnelone Feb 20 '13 at 9:49
  • Did you got the solution ? If not then try to clear the cache and view it again. :-) – mohit_rocks Feb 20 '13 at 9:50
  • I clear all caches but... still there. Maybe the path in my hook is wrong? – chefnelone Feb 20 '13 at 9:52
  • Your path seems right there is no problem in your code – mohit_rocks Feb 20 '13 at 9:54
  • The hook is not invoked, I tried to output dpm('hello') and I get nothing. 'function utilities_menu_alter(&$items) { dpm('hello'); }'In the same module I have a hook_form_alter() hook and dpm('hello') works (just to be sure that dmp() works) – chefnelone Feb 20 '13 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.