9

After block creation and put HTML content in body field I can't translate this content because of:

The string blocks:block:1:body for textgroup blocks is not allowed for translation because of its text format.

If I change to plain text I can translate block but it is treated as plain text while displaying. Do I have to create another block with the same HTML content (translated) and select to display only in specific language?

18

Found it, http://drupal.org/node/1298440#comment-5127390

In case anyone else has trouble finding this setting, it's at Configuration > Regional & Language > Multilingual Settings > Strings

(admin/config/regional/i18n/strings)

  • Thanks! I am always looking for this tweak, and your post saves my life everytime ;-) – DooKie Jan 22 '15 at 15:59

protected by Community Feb 9 '14 at 16:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.