0

I must have checked or unchecked a button somewhere, sometime, because ever since I remember starting to work on my site the titles of the pages are showing underneath the articles / texts on the pages, instead of on top of them, like they should. (example: see link to screenshot) I tried the 'manage display' option but I the title isn't part of that with the basic pages.

Does anyone have an idea of how I could fix this? :) For I have no clue...

Screenshot: http://img89.imageshack.us/img89/2140/headerunder.png

(the tags I wanted to use were not available for me so I hope I tagged this right..)

0

well propably is a theme issue. if you encounter this on all pages check your page.tpl.php and make sure this

  <?php if ($title): ?>
    <h1 class="title" id="page-title">
      <?php print $title; ?>
    </h1>
  <?php endif; ?>
  <?php print render($title_suffix); ?>

is before

<?php print render($page['content']); ?>

this is all i can say with the info provided.

  • I have used a few themes, and I've had this issue with all themes I've used, so while I thank you so much for your suggestion, I do not think it's a theme issue. However, I'd like to check the page.tpl.php, can you tell me where I might find that, in which folder? I'm just starting out and I don't have much experience with coding at all. :) – Claudi Feb 25 '13 at 9:34
  • sites/all/themes/<YOUR ENABLED THEME>/templates/.. – Pan Chrono Feb 25 '13 at 10:28
  • Thanks for that! :D I checked and it's in the correct order. – Claudi Feb 25 '13 at 10:41
  • well i had not in mind you were using any Display suite module or anything so your answer propably lies in there somewhere , try to disable it for starters ... never used modules like this, – Pan Chrono Feb 25 '13 at 11:00
0

The Display Suite Module offers you (among many many others) this functinality. With DS installed, you can rearrange your fields and more from every contenttype (and other entities) in your system. Very handy ...

  • I do happen to have Display Suite module--could you please tell me how to use that to put the title on top though? Because wherever I look, it doesn't show up in the options--only with articles, not with basic pages. :) – Claudi Feb 25 '13 at 9:40
  • You need to activate a "Layout". Go to your content type throug Display Suite and activate the "Full" viewmode. Switch to this viewmode then and choose a layout like "One Column" for example and save it. The extra fields will appear then in the list and you can start to rearrange them. – Lance Feb 25 '13 at 9:54
  • Thank you, Lance! I just tried that and it didn't work sadly. Well, partly; there's a title in the basic pages, but the contact form still has the title underneath like in the screenshot I showed. But maybe I don't really explain it well enough, probably since I don't understand it well enough. Here's a screenshot of another page--there's an extra header / title under the text: img14.imageshack.us/img14/7751/headerunder2.png – Claudi Feb 25 '13 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.