0

I have enabled the taxonomy/term/% view provided by the Views module but taxonomy term views are still handled by the core. Modifications has no effects and hooks such as hook_views_pre_render() are not invoked.

However, views explicitly specifying a term such as taxonomy/term/5 work.

Do you have any idea on how I can override the core default taxonomy?

0

You have to change the default view before it will take over. Add your customizations (for example, a field) to the taxonomy display, and save.

  • Thanks for your answer. I changed the default display, that's how I realized the view was not even called – znat Mar 3 '13 at 15:56
0

The Taxonomy views integrator module can help you; it allows selective overriding of taxonomy terms and/or vocabulary with the view of your choice.

  • TVI was the origin of the problem. Your answer helped me a lot as I probably would not have thought about that. – znat Mar 3 '13 at 19:18
0

The problem was that I had the Taxonomy View Integrator (TVI) module enabled. By default, if no override is set it invokes the core term page, which makes sense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.