1

I've been having problems to update modules through the admin feature.

I tried googling a lot about this issue but I always get other kind of module update issue but if this is answered elsewhere, please point me to it.

I don't recall how this started, I think around Drupal 7.18/7.19

What happens is that I get a daily email (from the cron) saying there are updates available. I go to ../admin/reports/updates/update, check all modules, update them all successfully. Then Drupal offers me to run updates in maintenance mode but when I click continue I get back to .../admin/update/ready with the site in maintenance mode activated. I retry and get back to the same page.

I run update.php and get "no pending update". Then I go to status report and all the modules appear updated but after a cron run, all the modules "go back" to the old version.

All this still happens after updating to 7.20

Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.