2

I am logged into my site as uid=1 (admin) but I cannot edit the /admin/config/group/roles/node/team page ("Team" is an Organic Group content type), due to getting an

"Access denied - You are not authorized to access this page."

I have cleared the cache, rebuilt the permissions, and tried a number of other tricks to gain access, all to no avail. Any ideas?

  • which is OG version using??? – monymirza Mar 5 '13 at 7:05
  • We are on Drupal 7.20 and OG is 7.x-2.0. I am under the impression the problem may have something to do with the incomplete integration of Workbench and og_workbench into this setup. Has anyone else got both workbench and og working? – cyboreal Mar 5 '13 at 22:33
  • take backup and reinstall(disable > uninstall > install again) og. try this – monymirza Mar 6 '13 at 5:51
8

If you temporarily disable og_workbench and it's still happening, you have a bigger problem. Was OG upgraded from 1.x -> 2.x?

I've found myself in this situation a few times during og upgrades. First, check to make sure all the OG Migrations have been run at admin/content/migrate. There is a migration named OgMigrateRoles that is often 0 of 0. Even though there is nothing to migrate, it still needs to run. If you do that and you still don't have access, check admin/config/group/permissions/node/[OG-ENABLED-CONTENT-TYPE]

You should see 3 columns w/ checkboxes for roles... NON-MEMBER, MEMBER, and ADMINISTRATOR MEMBER. If you see the rows permissions, but no checkboxes or roles your og_role table may be "hosed" for lack of a more technical term.

It is possible to manually repair this table by inserting rows for the 3 default roles for each of your og enabled content types. Something like...

INSERT INTO og_role (rid, gid, name, group_type, group_bundle) VALUES 
(1, 0, 'non-member', 'node', 'group'), 
(2, 0, 'member', 'node', 'group'),
(3, 0, 'administrator member', 'node', 'group');

The rid must be unique and 'group' should be replaced by your og enabled content type's machine name. Trying to manually repair the table isn't recommended and should only be used if you can't re-install... and even then only if you know your way around MySQL and on a test version of the site.

The good news is I've always been able to fix this with enough time and comparing the hosed og to a working OG2 install.

  • You may also have to manually update the og_membership table after you update og_role. Typically when og_role.group_type and og_role.group_bundle fail to update so too does og_membership.group_type and og_membership.field_name. The later two fields should be updated to match og_role_group_type and the field machine name for the users, nodes and entities referencing the group (og_group_ref is the default). – Brent Apr 24 '14 at 20:21
0

I just saw this problem when, for the first time, I added og_views to the group fields of a new group type. I created a group of this new group type and was then unable to edit the new group, even when logged in as admin. The reason was made clear when I visited the og group permissions: the check-box columns for the three default roles were missing. I hypothesized that og_views was to blame. I disabled it, uninstalled it, and removed the og_views module files from my file. I then succeeded in creating the group type, albeit without the field for group_views; and I was able to create and edits group of this type. I do not claim to have a proof that og_views was to blame; this is just a data point that seems to support the hypothesis. If your experience tends to affirm the hypothesis, please add your voice here. If a few people see the same thing, then we probably know where to look for the root cause.

0

I had this problem and I tried the fix running 5.7. It wasn't throwing the correct error. I found that the sessions table was corrupt. If you look in the logs you will find

Error - Can't open file: 'sessions.MYI'

Check and see if you can select from the sessions table. If not, then run

sql>repair table session;

FIXED

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.