1

I'm trying to translate the interface on a drupal 7 installation but somehow the terms and the taxonomy names are not being translated.

The vocabulary names and the terms names are already translated and the field names were also translated but the node creation form are still just showing on the default language.

Has anyone had the same problem?

Here's the page where this is happening: http://www.cuipcairo.org/ar/node/add/initiative

1

Figured it out.

It had to do with the fact that I was testing the Select (or other) taxonomy module, for Drupal 7.

On line 125 replaced

foreach ($taxonomy_terms as $term) {
    $options[$term->tid] = $term->name;
}

with

foreach ($taxonomy_terms as $term) {
    $options[$term->tid] = i18n_taxonomy_term_name(taxonomy_term_load($term->tid)); 
}

Still having trouble translating the field labels thought. Some how the t() function is not working on

'#title' => isset($instance['label']) ? t($title) : NULL, 
  • Is that solution is working for you if so that will be very helpful if you explain little more where you have did these changes to make it working? I am using term reference field in my content type with autocomplete widget. Thanks! – jas Jun 23 '16 at 7:33
1

Best guess based on your description is that you need to enable the URL detection at

/admin/config/regional/language/configure

since that appears to be how you are distinguishing the interface. This recipe from http://drupal.org/node/1281704#comment-5253460 should also help:

  • Enable ALL i18n modules
  • Add your extra languages (optional) - Enable Localization update and run Update translations at /admin/config/regional/translate/update
  • Enable URL detection method at /admin/config/regional/language/configure (optional) - Throw that Language Switcher block into a visible section of your site
  • Add your Localized vocabularies and translate them
  • Add your terms and translate them
  • Edit the content types you want term references to appear in and Enable Multilingual Support (with translation) in Publication Options vertical tab (recommended) - In the Synchronize Translations vertical tab check the first two checkboxes of the Extended language options. That is: "Set current language as default for new content" and "Require language (Do not allow Language Neutral)"
  • Add term reference fields to the content types you want
  • I've came across this thread already but unfortunately it did not work. – Pedro Gonçalves Mar 5 '13 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.