2

I want to limit the number of node created by the Feeds module, it hsould be limited to 5 each time.

I've added $conf['feeds_process_limit'] = 5; to the bottom of sites/default/settings.php

I've also changed FEEDS_PROCESS_LIMIT value in plugins/FeedsProcessor.inc to be 5

But still Feeds trying to import more than 5.

Looks like I've missed something. Anybody any hints about it?

1

You'll also need to clear your caches after setting $conf['feeds_process_limit'] = 50;.

Alternatively, if you are just looking for a quick limiter (during development of a custom importer, for example) this trick worked for me: Limit number of feed items to import ($conf['feeds_process_limit'] not working) (an active issue in the Feeds issue queue).

0

Try setting $conf['feeds_node_batch_size'] in your settings.php file. It looks like that is one of the variables that the feeds module looks at to determine how many items to process in each batch.

  • 1
    Isn't feeds_node_batch_size is applicable in Drupal 6? From readme: Variable 'feeds_node_batch_size' is now called 'feeds_process_limit' – apasajja Mar 8 '13 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.