0

I have a custom module named ta_module which alters the user registration form. But since I updated Views to version 7.x-3.0 - rc1, I have like a hundred errors barely the same as the following :

Warning: include_once(/{PRIVATE - DRUPAL ROOT FOLDER}/sites/all/modules/ta_module/views/theme/theme.inc) [function.include-once]: failed to open stream: No such file or directory in _theme_process_registry() (line 413 of /{PRIVATE - DRUPAL ROOT FOLDER}/includes/theme.inc).

Warning: include_once() [function.include]: Failed opening '/{PRIVATE - DRUPAL ROOT FOLDER}/sites/all/modules/ta_module/views/theme/theme.inc' for inclusion (include_path='.:/usr/local/lib/php') in _theme_process_registry() (line 413 of /{PRIVATE - DRUPAL ROOT FOLDER}/includes/theme.inc).

It seems like I need to create a /views/theme/theme.inc in my custom module folder. BUT TWO QUESTIONS REMAIN :

- Do I leave this file blank or am I supposed to put things in it ?

- Do I have to create other folders/files for Views not to interfere with my module ?

Thks for reading ! ;)

1 Answer 1

1

Have you tried clearing the cache?

The error is there because some module, expects that there is such a file and tries to include it. It could be a direct result of whatever views integration you are doing.

The error will go away if the file exists, an empty file with <?php is enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.