2

Drupal 6 site running on remote server.

I created a View of the User type. Then I create a display to show all users of my site. I set the Style of the display to Bulk Operation and in Selected operations I checked: Send e-mail (system_send_email_action)

In Fields I added the User: E-mail E-mail and other fields

Now I go to the path where I can see my users, I select one user (John) and click in send email under Bulk operation. I continue to complete a send the email and finally I get the message: 1 rows processed in about 23 ms: Performed Send E-mail on user John.

I understand that the email is sent to John user email from the administration site email.

But I don't receive the email. The email is not really sent.

I have a Webform node in my site which send email with no problems. So, I know there is nothing wrong with my server setting.

Thanks for any help

  • Don't know how it works exactly, but aren't those bulk emails sent by cron by any chance? If so, do you have cron running on your site? – Maciej Zgadzaj Jul 11 '11 at 15:53
3
+50

Just given it a quick test with VBO 1.10, and as you said, emails are not being sent. Also, got "Cannot use %author token in this context." error in log.

See this issue - http://drupal.org/node/1003354 - "Can't sent email (or 'send tokenized email') on a user view. Reverting to 6.x-1.9 works" - seems that 1.9 should work better, or - if dev is acceptable to you - 6.x-1.x-dev

Or use Views Send instead (http://drupal.org/project/views_send)

  • thanks maciej, I tried both reverting VBO and using Views Send. Stil not working. I think that I'm not sending the user email properly. Can you take a look a this picture which shows how is set my view: My view – chefnelone Jul 12 '11 at 8:06
  • And this is the error capture when using Views Send: error when using Views Send – chefnelone Jul 12 '11 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.