16

I have created a view with exposed filters of term select list. How can I make the select list to work directly on selecting an item, instead of clicking on the "Apply" button?

25

Under advanced portion of view choose following

**Exposed form**

 Exposed form style: Basic | Settings 

Then Choose autosubmit in Settings as shown below

enter image description here

This will hide the Apply button and the select list to work directly on selecting an item, instead of clicking on the Apply button.

  • I just configured as mentioned above, but now the filter is invisible. I use Views: 7.x-3.5 and BEF: 7.x-3.0-beta3 – AnAnD Mar 15 '13 at 6:24
  • you mean exposed filter? please recheck. The above solution works here properly – Anoop Joseph Mar 15 '13 at 6:27
  • Yes, exposed filter is invisible – AnAnD Mar 15 '13 at 6:34
  • 1
    yes it is available without better exposed filter also. i updated the answer – Anoop Joseph Mar 15 '13 at 6:47
  • 1
    Is there a solution for this problem in drupal 8? There doesn't seem to be an autosubmit checkbox and a hide submit button checkbox. Thanks. – cwiggo Mar 22 '16 at 13:37
0

If you're using Drupal 8. Choose Exposed form style as Autosubmit and then in Settings check Hide submit button checkbox.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.