0

I have the Drupal 7.21 installation and I am using a downloaded theme (premium responsive). I am trying to install an editor for my website entries but I have not been able to get it to work. This is the information on the two I have tried:

CKEditor version 4.0.2 and CKEditor Module 7.x-1.12 OR WYSIWYG Module version 7.x-2.2 with TinyMCE 3.5.8

I have carefully checked the installation instructions for all and they are correctly installed. I have been able to enable both (not at the same time, obviously) without any errors. However, when I try to add content I don't see the toolbars, only the plain white box.

So far it has been very frustrating. I have checked every thread that describes similar problems and tried every suggestion but it just won't work.

Can anyone provide a suggestion?

Thanks!

1
  1. Go to /admin/config/content/formats and make sure you have a text format for the role(s) you are working with.

  2. Go to /admin/config/content/wysiwyg and make sure you have added buttons to the editor (click on "Edit" and then under Buttons & Plugins).

  • Thanks for the answer. I had checked both suggestions above, and just for completeness I checked again and everything is set correctly. – Miguel Mar 17 '13 at 2:07
  • Ok. With TinyMCE the cache needs to be cleaned 100% first to see the changes. Please make sure you go to admin/config/development/performance and clean your cache. I would also clean your browser's cache. @Miguel – Otter Creative Studio Mar 17 '13 at 2:12
  • That was it!!!!! Once the cache was cleared I can see the editor. – Miguel Mar 17 '13 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.